summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStuart Hodgson <smhodgson@solarflare.com>2012-05-18 15:58:45 +0100
committerBen Hutchings <bhutchings@solarflare.com>2012-05-23 00:59:51 +0100
commit2edf56749abe006f6a68c9c21a2a249d29345a01 (patch)
tree2cfa7c4ff2a4c3658251bc031ad72703f41cd81a /Makefile.am
parent0d53f25de6f4f4499da2736805b652c0f2b51f99 (diff)
downloadethtool-2edf56749abe006f6a68c9c21a2a249d29345a01.tar.gz
ethtool: Addition of -m option to dump module eeprom
The -m option now allows for retrieval of EEPROM information form a plug in module such as SFP+. This shows specific information about the type and capabilities of the module in use The format can be easily extended to support other modules types such as QSFP in future. Raw data dump is also supported. Signed-off-by: Stuart Hodgson <smhodgson@solarflare.com> Signed-off-by: Ben Hutchings <bhutchings@solarflare.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 46a2cf2..789cd9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,7 @@ ethtool_SOURCES = ethtool.c ethtool-copy.h internal.h net_tstamp-copy.h \
fec_8xx.c ibm_emac.c ixgb.c ixgbe.c natsemi.c \
pcnet32.c realtek.c tg3.c marvell.c vioc.c \
smsc911x.c at76c50x-usb.c sfc.c stmmac.c \
- rxclass.c
+ rxclass.c sfpid.c
TESTS = test-cmdline
check_PROGRAMS = test-cmdline test-one-cmdline