summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAurelien Guillaume <aurelien@iwi.me>2012-12-02 21:21:01 +0100
committerBen Hutchings <bhutchings@solarflare.com>2012-12-03 16:54:48 +0000
commit749f3878693d21cd43301327ddd22811453e38da (patch)
tree98543995513d279f03c583592bbefccaa1d25ac5 /Makefile.am
parent08f7d492eb1de6f47313c6a9bcb07f32f1695513 (diff)
downloadethtool-749f3878693d21cd43301327ddd22811453e38da.tar.gz
Implemented basic optics diagnostics for SFF-8472
The current output of -m has been modified so that everything lines up correctly. The --module-info option alias has been added. Signed-off-by: Aurelien Guillaume <aurelien@iwi.me> Signed-off-by: Ben Hutchings <bhutchings@solarflare.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e33f71f..ba1faa6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,5 @@
AM_CFLAGS = -Wall
+LDADD = -lm
man_MANS = ethtool.8
EXTRA_DIST = LICENSE ethtool.8 ethtool.spec.in aclocal.m4 ChangeLog autogen.sh
@@ -9,7 +10,7 @@ ethtool_SOURCES = ethtool.c ethtool-copy.h internal.h net_tstamp-copy.h \
fec_8xx.c ibm_emac.c ixgb.c ixgbe.c natsemi.c \
pcnet32.c realtek.c tg3.c marvell.c vioc.c \
smsc911x.c at76c50x-usb.c sfc.c stmmac.c \
- rxclass.c sfpid.c
+ rxclass.c sfpid.c sfpdiag.c
TESTS = test-cmdline test-features
check_PROGRAMS = test-cmdline test-features