summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Hutchings <bhutchings@solarflare.com>2011-10-31 18:42:29 +0000
committerBen Hutchings <bhutchings@solarflare.com>2011-11-03 19:12:55 +0000
commitcfe91ed582a8947d6cdd5eee0bd3199f3ea265fa (patch)
treef346c604f9cba5d150f7f82a0732af852d5b6106 /Makefile.am
parent37897ca86845ac9f8df16ca424477baa3ac8c389 (diff)
downloadethtool-cfe91ed582a8947d6cdd5eee0bd3199f3ea265fa.tar.gz
Add test cases for command-line parsing
Preparation for refactoring command-line parsing. All these test cases pass. Signed-off-by: Ben Hutchings <bhutchings@solarflare.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e05640..4b0eb17 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,6 +11,13 @@ ethtool_SOURCES = ethtool.c ethtool-copy.h internal.h \
smsc911x.c at76c50x-usb.c sfc.c stmmac.c \
rxclass.c
+TESTS = test-cmdline
+check_PROGRAMS = test-cmdline test-one-cmdline
+test_cmdline_SOURCES = test-cmdline.c test-common.c
+test_cmdline_CFLAGS = -DTEST_ETHTOOL
+test_one_cmdline_SOURCES = $(ethtool_SOURCES)
+test_one_cmdline_CFLAGS = -DTEST_ETHTOOL
+
dist-hook:
cp $(top_srcdir)/ethtool.spec $(distdir)