summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Hutchings <bhutchings@solarflare.com>2012-02-17 22:17:41 +0000
committerBen Hutchings <bhutchings@solarflare.com>2012-06-02 01:31:02 +0100
commitf2686c1e2b988af68e0bf14cacde254b487fd4f2 (patch)
tree1c44f0db26c06ee3d4f928479866284f5e77da01 /Makefile.am
parent70943b52befd3dfd0de276aebd5f771bbf4e6fbc (diff)
downloadethtool-f2686c1e2b988af68e0bf14cacde254b487fd4f2.tar.gz
Add unit tests for setting offload features (old API)
Signed-off-by: Ben Hutchings <bhutchings@solarflare.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d1aec43..1b96b98 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,10 +11,12 @@ ethtool_SOURCES = ethtool.c ethtool-copy.h internal.h net_tstamp-copy.h \
smsc911x.c at76c50x-usb.c sfc.c stmmac.c \
rxclass.c sfpid.c
-TESTS = test-cmdline
-check_PROGRAMS = test-cmdline
+TESTS = test-cmdline test-features
+check_PROGRAMS = test-cmdline test-features
test_cmdline_SOURCES = test-cmdline.c test-common.c $(ethtool_SOURCES)
test_cmdline_CFLAGS = -DTEST_ETHTOOL
+test_features_SOURCES = test-features.c test-common.c $(ethtool_SOURCES)
+test_features_CFLAGS = -DTEST_ETHTOOL
dist-hook:
cp $(top_srcdir)/ethtool.spec $(distdir)