summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>1997-12-23 17:30:17 +0000
committerWerner Koch <wk@gnupg.org>1997-12-23 17:30:17 +0000
commit845ea7e9fe5573a6a6f83614f4f2345a4e957028 (patch)
treeebc26f8b3ebba3c24a82cac767a04cd2f3088763 /Makefile.am
parent051a55b072253c6580b5d3aa62489c93dba780e4 (diff)
downloadlibgcrypt-845ea7e9fe5573a6a6f83614f4f2345a4e957028.tar.gz
changed configuration stuff, replaced some Makefile.am by distfiles.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 11d469c7..4a2c3a20 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = scripts include util mpi cipher tools g10
+SUBDIRS = util mpi cipher tools g10
EXTRA_DIST =
@@ -9,4 +9,13 @@ tar: clean
cd ..; tar czvf ~/bkup/g10-`date +%d%m`.tar.gz src
+dist-hook:
+ @set -e; \
+ for file in `find $(srcdir) -type f -name distfiles`; do \
+ dir=`dirname $$file` ; $(mkinstalldirs) $(distdir)/$$dir ; \
+ for i in distfiles `cat $$file` ; do \
+ ln $(srcdir)/$$dir/$$i $(distdir)/$$dir/$$i 2> /dev/null \
+ || cp -p $(srcdir)/$$dir/$$i $(distdir)/$$dir/$$i; \
+ done ; \
+ done