summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2013-10-23 18:36:10 +0300
committerJussi Kivilinna <jussi.kivilinna@iki.fi>2013-10-23 18:36:10 +0300
commit10bf6a7e16ed193f90d2749970a420f00d1d3320 (patch)
treec931cd1d319d2310b96dfb1ebc00cfee104b1897 /configure.ac
parent164eb8c85d773ef4f0939115ec45f5e4b47c1700 (diff)
downloadlibgcrypt-10bf6a7e16ed193f90d2749970a420f00d1d3320.tar.gz
Correct ASM assembly test in configure.ac
* configure.ac: correct HAVE_COMPATIBLE_GCC_ARM_PLATFORM_AS test to require neither ARMv6, nor thumb mode. Our assembly code works perfectly even on ARMv4 now. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 69cfbd23..a1ffdc7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1109,11 +1109,10 @@ AC_CACHE_CHECK([whether GCC assembler is compatible for ARM assembly implementat
[[__asm__(
/* Test if assembler supports UAL syntax. */
".syntax unified\n\t"
- ".thumb\n\t" /* thumb-2 in UAL, thumb-1 otherwise. */
- ".code 16\n\t"
+ ".arm\n\t" /* our assembly code is in ARM mode */
/* Following causes error if assembler ignored '.syntax unified'. */
"asmfunc:\n\t"
- "add.w %r0, %r4, %r8, ror #12;\n\t"
+ "add %r0, %r0, %r4, ror #12;\n\t"
/* Test if '.type' and '.size' are supported. */
".size asmfunc,.-asmfunc;\n\t"