summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-11-18 16:21:42 -0800
committerGerald Combs <gerald@wireshark.org>2014-12-09 21:25:33 +0000
commit4921e559906aee70c4665f1c739057e227787e01 (patch)
tree4465cb9e9de152bfb57f00852e437994e2d85cd9 /CMakeLists.txt
parent3147087de323c0294b51006f97b641fc408f1b06 (diff)
downloadwireshark-4921e559906aee70c4665f1c739057e227787e01.tar.gz
Qt: Initial VoIP Calls dialog.
Add Telephony menu items for VoIP Calls and SIP Flows. Put VoIP Calls at the top, since that seems to be the primary item. Add configure-time checks for QtMultimediaWidgets in anticipation of adding a VoIP playback dialog. Add an icon for the playback button. (Yes, I've been avoiding GNOME-level gratuitous icons so far but this is one of the rare occiasions where it makes sense.) Add a help link define for the VoIP calls dialog. Change-Id: I5d0799685c598ad9af76fe9667f8ea7d14b66050 Reviewed-on: https://code.wireshark.org/review/5674 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4639b94a17..bc0234b9fd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -529,7 +529,12 @@ if(BUILD_wireshark)
set( QT5_DLL_PATH "${QT5_BASE_PATH}/bin" )
set( WS_ALL_LIBS ${WS_ALL_LIBS} ${QT5_DLL_PATH} )
endif()
- set(PACKAGELIST ${PACKAGELIST} Qt5Widgets Qt5PrintSupport Qt5LinguistTools)
+ set(PACKAGELIST ${PACKAGELIST}
+ Qt5LinguistTools
+ Qt5MultimediaWidgets
+ Qt5PrintSupport
+ Qt5Widgets
+ )
if (APPLE)
set(PACKAGELIST ${PACKAGELIST} Qt5MacExtras)
endif()
@@ -732,6 +737,11 @@ if (Qt5Widgets_FOUND)
endif()
set (QT_FOUND ON)
set (QT_LIBRARIES ${Qt5Widgets_LIBRARIES} ${Qt5PrintSupport_LIBRARIES})
+ if(Qt5MultimediaWidgets_FOUND)
+ set (QT_LIBRARIES ${QT_LIBRARIES} ${Qt5MultimediaWidgets_LIBRARIES})
+ # That's the name autofoo uses
+ set(QT_MULTIMEDIAWIDGETS_LIB 1)
+ endif()
if(Qt5MacExtras_FOUND)
set (QT_LIBRARIES ${QT_LIBRARIES} ${Qt5MacExtras_LIBRARIES})
# That's the name autofoo uses