summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-05-04 20:06:43 -0700
committerGuy Harris <guy@alum.mit.edu>2014-05-05 03:07:21 +0000
commit0b0c98a040493d8ff052d9513d0a6aa8f6b656c1 (patch)
tree025912625edf11059f28befc204aad763d77e850 /CMakeLists.txt
parent19e650f43adf23b0aa92821bff0cc389643944f6 (diff)
downloadwireshark-0b0c98a040493d8ff052d9513d0a6aa8f6b656c1.tar.gz
set(<variable>) *undefines* the variable; a value must be specified.
When setting the XXX_REQUIRED variables, set them to TRUE. Change-Id: I1591ffe221e15d65cb64516a45e9dc8461051373 Reviewed-on: https://code.wireshark.org/review/1497 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e50de6abd0..0d48ce067c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -425,11 +425,11 @@ endif()
#The minimum package list
set(PACKAGELIST Gettext GLIB2 GMODULE2 GTHREAD2 M LEX YACC Perl SED SH PythonInterp)
-set(GLIB2_REQUIRED)
-set(GLIB2_FIND_REQUIRED)
+set(GLIB2_REQUIRED TRUE)
+set(GLIB2_FIND_REQUIRED TRUE)
set(GLIB2_MIN_VERSION 2.14.0)
-set(GTHREAD2_REQUIRED)
-set(M_REQUIRED)
+set(GTHREAD2_REQUIRED TRUE)
+set(M_REQUIRED TRUE)
set(PythonInterp_FIND_VERSION 2)
set(Python_ADDITIONAL_VERSIONS 3)