summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2014-04-26 23:18:19 +0100
committerAnders Broman <a.broman58@gmail.com>2014-04-29 04:25:26 +0000
commit14017dc6f1638c43afa47611d5aa32513ce36850 (patch)
tree1ec7251bc5d6e1c4e8bf150b139fcfe32e1d0e97 /CMakeLists.txt
parent8d4db3e40b95ef39a34fdcc0b4454bd459606672 (diff)
downloadwireshark-14017dc6f1638c43afa47611d5aa32513ce36850.tar.gz
Set CMake defaults for Windows build to:
Use GTK2 as per nmake. Not to build the dumpabi executables. Change-Id: Ia28cf1a80b81e10595f4af5bbd46da3b3675faf5 Reviewed-on: https://code.wireshark.org/review/1376 Reviewed-by: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Graham Bloice <graham.bloice@trihedral.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ccf0b8219c..659cfd5952 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -711,7 +711,9 @@ add_subdirectory( ui )
add_subdirectory( wiretap )
add_subdirectory( wsutil )
-add_custom_target(dumpabi DEPENDS dumpabi-libwireshark dumpabi-libfiletap dumpabi-libwiretap dumpabi-libwsutil color.h)
+if(NOT WIN32)
+ add_custom_target(dumpabi DEPENDS dumpabi-libwireshark dumpabi-libfiletap dumpabi-libwiretap dumpabi-libwsutil color.h)
+endif()
if(ENABLE_ECHLD)
add_subdirectory( echld )