summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2013-12-04 10:41:38 +0000
committerJörg Mayer <jmayer@loplof.de>2013-12-04 10:41:38 +0000
commitcf82d056f2281001edee70eb73fd0310703a4b2f (patch)
tree55961d3300004421f5db6dae933d60c7a8873220 /CMakeLists.txt
parent2e0fbbfe26cecb25c8d250794d386c0bee5700e0 (diff)
downloadwireshark-cf82d056f2281001edee70eb73fd0310703a4b2f.tar.gz
Create all binaries in one directory. After running setpath.bat
wireshark etc should now work, the basic stuff at least. Known problems/todos: - The plugins are not searched for in the current directory, so find out how to let Wireshark know to search for the plugins - Other supporting files are missing (COPYING.txt, AUTHORS*, ...) - Your missing feature could be listed here ;) Ciao Jörg svn path=/trunk/; revision=53780
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 664e9a683f..f9c3a57c4b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,9 +122,17 @@ include_directories(
${CMAKE_SOURCE_DIR}/wiretap
)
-#Where to put libraries
+#Where to put executables and libraries in the build tree
+if(NOT ARCHIVE_OUTPUT_PATH)
+ set(ARCHIVE_OUTPUT_PATH ${Wireshark_BINARY_DIR}/run CACHE INTERNAL
+ "Single output directory for building all archives.")
+endif()
+if(NOT EXECUTABLE_OUTPUT_PATH)
+ set(EXECUTABLE_OUTPUT_PATH ${Wireshark_BINARY_DIR}/run CACHE INTERNAL
+ "Single output directory for building all executables.")
+endif()
if(NOT LIBRARY_OUTPUT_PATH)
- set(LIBRARY_OUTPUT_PATH ${Wireshark_BINARY_DIR}/lib CACHE INTERNAL
+ set(LIBRARY_OUTPUT_PATH ${Wireshark_BINARY_DIR}/run CACHE INTERNAL
"Single output directory for building all libraries.")
endif()