summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2015-03-26 14:11:21 +0000
committerGraham Bloice <graham.bloice@trihedral.com>2015-03-26 16:58:53 +0000
commit01947acc5ae8d5a5c99456d419800dd4c602d775 (patch)
tree289e690644921bf61f4cbd76f7378cc48ea64e57 /CMakeLists.txt
parenta5963612286c706146d477042b722d34d9ba20d7 (diff)
downloadwireshark-01947acc5ae8d5a5c99456d419800dd4c602d775.tar.gz
CMake updates for Windows build
Removed the redundant setpath batch file and associated macro and updated docs. Change-Id: I5ddab6bad2d14ed3443194d7269f1890e4aa608e Reviewed-on: https://code.wireshark.org/review/7826 Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a983f3c17..c0da586b34 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -562,9 +562,6 @@ if(BUILD_wireshark)
if( WIN32 )
set( QT5_BASE_PATH "$ENV{QT5_BASE_DIR}" )
set( CMAKE_PREFIX_PATH "${QT5_BASE_PATH}" )
- # Used for the creation of setpath.bat
- set( QT5_DLL_PATH "${QT5_BASE_PATH}/bin" )
- set( WS_ALL_LIBS ${WS_ALL_LIBS} ${QT5_DLL_PATH} )
endif()
set(PACKAGELIST ${PACKAGELIST}
Qt5Core
@@ -720,9 +717,6 @@ endforeach()
# Provide Windows system lib names
include( UseWinLibs )
-# Create file to set paths to run binaries from build dir
-WSExtendPath( "${WS_ALL_LIBS}" "${CMAKE_BINARY_DIR}/setpath.bat" )
-
#packaging
include(CPackConfig.txt)