summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnders <anders.broman@ericsson.com>2015-05-29 10:33:58 +0200
committerAnders Broman <a.broman58@gmail.com>2015-08-13 12:03:53 +0000
commit738cf424d698ea56a680d79c5039703492e1a7ff (patch)
treedd17f4666b0941fda67414a7ee602f471cccee23 /CMakeLists.txt
parent6087f2a2608f1c841e2a1af51d5fdef98906f965 (diff)
downloadwireshark-738cf424d698ea56a680d79c5039703492e1a7ff.tar.gz
Make building with MSVC2015 work
TODO: - LUA is commented out probably needs to be built with MSVC 2015. - GeoIP is commented out, causes packet-ip* to not build. - Qt not built, needs Qt with MSVC 2015 Change-Id: I1658077931b89b9a22ee32e5ed7de38e07fb6a55 Reviewed-on: https://code.wireshark.org/review/8683 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 334613ef51..2e5ea9d617 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,7 +110,9 @@ if(WIN32)
# Download third-party libraries
file (TO_NATIVE_PATH ${CMAKE_SOURCE_DIR}/tools/win-setup.ps1 _win_setup)
file (TO_NATIVE_PATH ${_PROJECT_LIB_DIR} _ws_lib_dir)
- if(MSVC12)
+ if(MSVC14)
+ set(_vsversion_args "14")
+ elseif(MSVC12)
set(_vsversion_args "12")
elseif(MSVC11)
set(_vsversion_args "11")
@@ -231,6 +233,8 @@ if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
set(MSC_VER_REQUIRED 1700)
elseif(MSVC12)
set(MSC_VER_REQUIRED 1800)
+ elseif(MSVC14)
+ set(MSC_VER_REQUIRED 1900)
else()
message(FATAL_ERROR "You are using an unsupported version of MSVC")
endif()
@@ -279,6 +283,11 @@ if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
# Assume all VS2013 builds are at least Update 3.
# See http://msdn.microsoft.com/en-us/library/dn785163.aspx
set(LOCAL_CFLAGS ${LOCAL_CFLAGS} "/Zo")
+ elseif(MSVC14)
+ # /Zo Enhanced debugging of optimised codem for VS2013 Update 3 and beyond,
+ # Assume all VS2013 builds are at least Update 3.
+ # See http://msdn.microsoft.com/en-us/library/dn785163.aspx
+ set(LOCAL_CFLAGS ${LOCAL_CFLAGS} "/Zo")
endif()
if(ENABLE_CODE_ANALYSIS)