summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2015-10-09 16:26:24 +0200
committerPeter Wu <peter@lekensteyn.nl>2015-10-14 16:46:35 +0000
commit75dc21bd97da2211e4bc26c4a87b208ce771b29a (patch)
tree1b86320bb3272132c811d2e1897a66c4ef4ae9d9 /CMakeLists.txt
parente4caf132d7b2da30d0d88f50c7cdc4d3603202e0 (diff)
downloadwireshark-75dc21bd97da2211e4bc26c4a87b208ce771b29a.tar.gz
cmake: fix kerberos library lookup, support Heimdal
A build with the gold linker broke with: run/libwireshark.so.0.0.0: error: undefined reference to 'krb5_c_decrypt' Fix this my restructuring the FindKERBEROS module to use the libraries found by pkg-config. While at it, check for MIT and Heimdal instead of assuming MIT. Remove HAVE_KEYTYPE_ARCFOUR_56 as this macro is not used. Change-Id: Iab23d79bc3f25e9c0fd7203b6f050f875fb4a2b5 Reviewed-on: https://code.wireshark.org/review/10907 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Jörg Mayer <jmayer@loplof.de> Reviewed-by: Peter Wu <peter@lekensteyn.nl> (cherry picked from commit 01f82ee84cc849aa7c2f344d2067f0d81715490d) Reviewed-on: https://code.wireshark.org/review/11036
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 341666afed..89baf25d0c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -834,9 +834,6 @@ if(HAVE_LIBLUA)
endif()
if(HAVE_LIBKERBEROS)
set(HAVE_KERBEROS 1)
- # HAVE_HEIMDAL_KERBEROS
- set(HAVE_MIT_KERBEROS 1)
- set(HAVE_KEYTYPE_ARCFOUR_56 1)
endif()
if(HAVE_LIBGEOIP)
set(HAVE_GEOIP 1)