summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-11-17 12:33:47 -0800
committerGerald Combs <gerald@wireshark.org>2015-11-17 22:46:05 +0000
commit804ee98b32bfd3fe39e67210da5569da8336ecda (patch)
tree569086093b774373b400ee9dd381befdb8888231 /CMakeLists.txt
parentd7806f9089fc66de90ea2d8ec638ffdaf21727ff (diff)
downloadwireshark-804ee98b32bfd3fe39e67210da5569da8336ecda.tar.gz
CMake: Add Qt5Svg to PACKAGELIST.
...otherwise we won't copy it to ${CMAKE_BINARY_DIR}/run/Wireshark.app on OS X, which means our flag icons won't be displayed. Bug: 11697 Change-Id: I26cd6a2dd13be35f9a80fd93adc8248848df5978 Reviewed-on: https://code.wireshark.org/review/11923 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org> (cherry picked from commit e3eb9f32081dafd97e058bf292e130e511f33748) Reviewed-on: https://code.wireshark.org/review/11929
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da7b4e0513..012c3f0d46 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -678,6 +678,7 @@ if(BUILD_wireshark)
Qt5LinguistTools
Qt5Multimedia
Qt5PrintSupport
+ Qt5Svg
Qt5Widgets
)
if (APPLE)
@@ -923,6 +924,11 @@ if (Qt5Widgets_FOUND)
# That's the name autofoo uses
set(QT_MULTIMEDIA_LIB 1)
endif()
+ if(Qt5Svg_FOUND)
+ set (QT_LIBRARIES ${QT_LIBRARIES} ${Qt5Svg_LIBRARIES})
+ # That's the name autofoo uses
+ set(QT_SVG_LIB 1)
+ endif()
if(Qt5MacExtras_FOUND)
set (QT_LIBRARIES ${QT_LIBRARIES} ${Qt5MacExtras_LIBRARIES})
# That's the name autofoo uses