summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Labedzki <michal.labedzki@tieto.com>2015-02-14 19:10:21 +0100
committerMichal Labedzki <michal.labedzki@tieto.com>2015-04-08 09:57:24 +0000
commitb99cf21c2546bc8260d50f17e60ab614092dac24 (patch)
tree174ffadfa3b220192e64244f9d17fdfb1e0a80bf /CMakeLists.txt
parentf3d2cb5881f320386ca8c4af26053121811edbec (diff)
downloadwireshark-b99cf21c2546bc8260d50f17e60ab614092dac24.tar.gz
extcap: Add support for Android - androiddump
androiddump is extcap program that can be used with Android devices (need Android SDK in system PATH). Supported is Logcat/Logger logs and Bluetooth interfaces for all Android to this day (Lollipop). Please note that it will work also for FirefoxOS. Interfaces: 1. Logcat Main (binary or text) 2. Logcat System (binary or text) 3. Logcat Events (binary or text) 4. Logcat Radio (binary or text) 5. Logcat Crash (text; Lollipop) 6. Bluetooth Hcidump (<Kitkat) 7. Bluetooth Bluedroid External Parser (Kitkat) 8. Bluetooth BtsnoopNet (Lollipop) Change-Id: I26e4cd1a37a6af805f8b932399b4aa44ee7b5a80 Reviewed-on: https://code.wireshark.org/review/7475 Petri-Dish: Michal Labedzki <michal.labedzki@tieto.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Michal Labedzki <michal.labedzki@tieto.com> Tested-by: Michal Labedzki <michal.labedzki@tieto.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58ed434a49..b446bbde1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -763,6 +763,9 @@ endif()
if(HAVE_LIBSBC)
set(HAVE_SBC 1)
endif()
+if(EXTCAP_ANDROIDDUMP_LIBPCAP)
+ set(ANDROIDDUMP_USE_LIBPCAP 1)
+endif()
if (HAVE_LIBWINSPARKLE)
set(HAVE_SOFTWARE_UPDATE 1)
@@ -2083,6 +2086,39 @@ if (WIN32)
endif()
endif()
+if(BUILD_androiddump)
+ if(EXTCAP_ANDROIDDUMP_LIBPCAP)
+ if(HAVE_LIBPCAP)
+ set(androiddump_LIBS
+ ${GLIB2_LIBRARIES}
+ ${PCAP_LIBRARIES}
+ )
+ else()
+ message(FATAL_ERROR "You try to build androiddump with libpcap but do not have it")
+ endif()
+ else()
+ set(androiddump_LIBS
+ wiretap
+ ${GLIB2_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+ )
+ endif()
+ set(androiddump_FILES
+ ${GLIB2_LIBRARIES}
+ extcap/androiddump.c
+ )
+
+ set(COPY_CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/run/extcap)
+ add_executable(androiddump ${androiddump_FILES})
+ add_dependencies(androiddump gitversion)
+ set_target_properties(androiddump PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
+ set_target_properties(androiddump PROPERTIES FOLDER "Executables/Extcaps")
+ target_link_libraries(androiddump ${androiddump_LIBS})
+ install(TARGETS androiddump RUNTIME DESTINATION ${EXTCAP_DIR})
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${COPY_CMAKE_RUNTIME_OUTPUT_DIRECTORY})
+endif()
+
ADD_CUSTOM_COMMAND(
OUTPUT ${CMAKE_BINARY_DIR}/AUTHORS-SHORT
COMMAND ${PERL_EXECUTABLE}