summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2015-10-08 23:57:22 +0200
committerPeter Wu <peter@lekensteyn.nl>2015-10-14 22:50:30 +0000
commiteea2dfa0894d47f47480230152243d1ef2ba6f38 (patch)
tree7f9445d3b3b48cb2c5ee35fa853327e5474453a3 /CMakeLists.txt
parentc35ea230f3c12ed064d08872f65a4a4147454a29 (diff)
downloadwireshark-eea2dfa0894d47f47480230152243d1ef2ba6f38.tar.gz
cmake: always enable -Qunused-arguments for clang
"argument unused during compilation" warnings suggest that some options do not make sense (such as passing the -gsplit-dwarf option to the linking command while it is only valid during compilation). For now we do not care about these warnings, the option is accepted by clang and whether it used in a particular step or not is uninteresting. Change-Id: I3b6efa0dccd33c7f351c5938a29adef64ac1706d Reviewed-on: https://code.wireshark.org/review/10893 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> (cherry picked from commit e059e4588636bbe88b3706b962469a2003550b51) Reviewed-on: https://code.wireshark.org/review/11038
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89baf25d0c..590172ca78 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -440,13 +440,13 @@ else()
if(CMAKE_C_COMPILER_ID MATCHES "Clang")
set(WIRESHARK_COMMON_FLAGS ${WIRESHARK_COMMON_FLAGS}
- #-fcolor-diagnostics
+ # avoid "argument unused during compilation" warnings
+ # (for example, when getting the -gsplit-dwarf option or
+ # when combining -fwrapv with -fno-strict-overflow)
+ -Qunused-arguments
)
- # ccache + clang++ can result in "argument unused during
- # compilation" warnings.
set(WIRESHARK_CPP_ONLY_FLAGS ${WIRESHARK_CPP_ONLY_FLAGS}
- -Qunused-arguments
)
else()
set(WIRESHARK_COMMON_FLAGS ${WIRESHARK_COMMON_FLAGS}