summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2015-01-14 22:59:21 +0000
committerGerald Combs <gerald@wireshark.org>2015-01-15 16:19:17 +0000
commit58bb07ba5c070e0ef25e42e20e4696524d5a6c3e (patch)
tree533e386ee27d870bb3bd55be4874425b03919f56 /CMakeLists.txt
parenta1fce22373cc4987a3ab514ad9811d54e02d3efe (diff)
downloadwireshark-58bb07ba5c070e0ef25e42e20e4696524d5a6c3e.tar.gz
Fix-copy-qt-dll
The copy-qt-dll custom command should ensure the qt bin dir is on the path. Modify the flags passed to windeployqt depending on the configuration. Change-Id: I12860d415f80cee323c72aa8a4892eaa6126f165 Reviewed-on: https://code.wireshark.org/review/6537 Reviewed-by: Graham Bloice <graham.bloice@trihedral.com> Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index efc02bf387..6e4328d0f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1428,9 +1428,13 @@ if(BUILD_wireshark AND QT_FOUND)
add_custom_target(copy_qt_dlls ALL)
# Will we ever need to use --debug? Windeployqt seems to
# be smart enough to copy debug DLLs when needed.
- add_custom_command(TARGET copy_qt_dlls POST_BUILD
+ add_custom_command(TARGET copy_qt_dlls
+ POST_BUILD
+ COMMAND set "PATH=%PATH%;${_qt_bindir}"
COMMAND "${_windeployqt}"
- --release --no-compiler-runtime
+ $<$<CONFIG:Debug>:--debug>
+ $<$<NOT:$<CONFIG:Debug>>:--release>
+ --no-compiler-runtime
"$<TARGET_FILE:wireshark>"
)
add_dependencies(copy_qt_dlls wireshark)