summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-01-01 01:19:57 -0800
committerGuy Harris <guy@alum.mit.edu>2015-01-01 10:46:00 +0000
commit8bf7078f7929d45c004372998aa3a87c05d43671 (patch)
tree7f1aae774dcd339ff47b4f591500a7803805b029 /CMakeLists.txt
parenta4019a357bfa9492fd2a4f35bb97a25eb2af9fe8 (diff)
downloadwireshark-8bf7078f7929d45c004372998aa3a87c05d43671.tar.gz
Move ui/qt/main.cpp to wireshark-qt.cpp, and get rid of the dummy.cpp hack.
Change-Id: Ib4684264363593372b3bf078cf17cae1a1cb10d6 Reviewed-on: https://code.wireshark.org/review/6199 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1554fb4e5b..a2ba6750ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1142,6 +1142,9 @@ if( (BUILD_wireshark AND QT_FOUND) OR (BUILD_wireshark_gtk AND GTK_FOUND) )
${SHARK_COMMON_SRC}
${PLATFORM_UI_SRC}
)
+ if(BUILD_wireshark AND QT_FOUND)
+ set(WIRESHARK_SRC ${WIRESHARK_SRC} wireshark-qt.cpp)
+ endif()
set(wireshark_FILES
${WIRESHARK_SRC}
image/wireshark.rc