summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-03-12 14:44:01 -0700
committerGuy Harris <guy@alum.mit.edu>2014-03-12 21:44:44 +0000
commit0284e87bea177188343d3ce9ebdfe2ec0d4044b7 (patch)
tree9e3feea728b6fdbaade8af1a01b32181f613d5fd /Makefile.am
parent5ae2815615d04e63c99c4636e5fdf644d7c5abc9 (diff)
downloadwireshark-0284e87bea177188343d3ce9ebdfe2ec0d4044b7.tar.gz
Consistently put -lm at the end of library lists.
I'm not sure why it's associated with GLIB_LIBS in most entries - at some point, was it the case that we didn't use libmath routines but GLib did? - but there's no guarantee that other libraries don't use them, so put them at the end of the lists. That also makes the lists a bit more consistent. (Yes, I know, the wireshark_ldadd list is followed by some other libraries in the library lists that use it, so -lm isn't *really* at the end everywhere.) Change-Id: Ia2e0b295fdaae771fdee7d5eecdefaa83fae9992 Reviewed-on: https://code.wireshark.org/review/622 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 23 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index 5a4085cb16..30c9701881 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -435,7 +435,7 @@ tshark_LDADD = \
wsutil/libwsutil.la \
@SSL_LIBS@ \
$(plugin_ldadd) \
- @GLIB_LIBS@ -lm \
+ @GLIB_LIBS@ \
@PCAP_LIBS@ \
@SOCKET_LIBS@ \
@NSL_LIBS@ \
@@ -447,7 +447,8 @@ tshark_LDADD = \
@PY_LIBS@ \
@LIBGCRYPT_LIBS@ \
@LIBGNUTLS_LIBS@ \
- @LIBSMI_LDFLAGS@
+ @LIBSMI_LDFLAGS@ \
+ -lm
tshark_CFLAGS = $(AM_CLEAN_CFLAGS) $(py_dissectors_dir)
if ENABLE_STATIC
@@ -466,7 +467,7 @@ tfshark_LDADD = \
wsutil/libwsutil.la \
@SSL_LIBS@ \
$(plugin_ldadd) \
- @GLIB_LIBS@ -lm \
+ @GLIB_LIBS@ \
@PCAP_LIBS@ \
@SOCKET_LIBS@ \
@NSL_LIBS@ \
@@ -475,7 +476,8 @@ tfshark_LDADD = \
@COREFOUNDATION_FRAMEWORKS@ \
@PY_LIBS@ \
@LIBGNUTLS_LIBS@ \
- @LIBSMI_LDFLAGS@
+ @LIBSMI_LDFLAGS@ \
+ -lm
tfshark_CFLAGS = $(AM_CLEAN_CFLAGS) $(py_dissectors_dir)
if ENABLE_STATIC
@@ -492,7 +494,7 @@ rawshark_LDADD = \
wsutil/libwsutil.la \
@SSL_LIBS@ \
$(plugin_ldadd) \
- @GLIB_LIBS@ -lm \
+ @GLIB_LIBS@ \
@PCAP_LIBS@ \
@SOCKET_LIBS@ \
@NSL_LIBS@ \
@@ -504,13 +506,15 @@ rawshark_LDADD = \
@PY_LIBS@ \
@LIBGCRYPT_LIBS@ \
@LIBGNUTLS_LIBS@ \
- @LIBSMI_LDFLAGS@
+ @LIBSMI_LDFLAGS@ \
+ -lm
rawshark_CFLAGS = $(AM_CLEAN_CFLAGS) $(py_dissectors_dir)
# Libraries with which to link text2pcap.
text2pcap_LDADD = \
wsutil/libwsutil.la \
- @GLIB_LIBS@ -lm
+ @GLIB_LIBS@ \
+ -lm
# Don't turn on -Werror for text2pcap: its source includes text2pcap-scanner.c
# which is generated (and therefore not always clean).
# We could generate text2pcap.o as a library with -Werror but for now it
@@ -557,12 +561,13 @@ reordercap_CFLAGS = $(AM_CLEAN_CFLAGS)
randpkt_LDADD = \
wiretap/libwiretap.la \
wsutil/libwsutil.la \
- @GLIB_LIBS@ -lm \
+ @GLIB_LIBS@ \
@PCAP_LIBS@ \
@SOCKET_LIBS@ \
@NSL_LIBS@ \
@C_ARES_LIBS@ \
- @ADNS_LIBS@
+ @ADNS_LIBS@ \
+ -lm
randpkt_CFLAGS = $(AM_CLEAN_CFLAGS)
# Libraries and plugin flags with which to link dftest.
@@ -573,7 +578,7 @@ dftest_LDADD = \
epan/libwireshark.la \
@SSL_LIBS@ \
$(plugin_ldadd) \
- @GLIB_LIBS@ -lm \
+ @GLIB_LIBS@ \
@PCAP_LIBS@ \
@SOCKET_LIBS@ \
@NSL_LIBS@ \
@@ -583,19 +588,21 @@ dftest_LDADD = \
@PY_LIBS@ \
@LIBGCRYPT_LIBS@ \
@LIBGNUTLS_LIBS@ \
- @LIBSMI_LDFLAGS@
+ @LIBSMI_LDFLAGS@ \
+ -lm
dftest_CFLAGS = $(AM_CLEAN_CFLAGS) $(py_dissectors_dir)
echld_test_LDADD = \
- epan/libwireshark.la \
- echld/libechld.la \
- wsutil/libwsutil.la \
- @GLIB_LIBS@ -lm \
+ epan/libwireshark.la \
+ echld/libechld.la \
+ wsutil/libwsutil.la \
+ @GLIB_LIBS@ \
@PCAP_LIBS@ \
@SOCKET_LIBS@ \
@NSL_LIBS@ \
@C_ARES_LIBS@ \
- @ADNS_LIBS@
+ @ADNS_LIBS@ \
+ -lm
echld_test_DEPENDENCIES = \
echld/libechld.la \