summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-09-16 13:12:10 -0700
committerGerald Combs <gerald@wireshark.org>2014-09-16 20:22:27 +0000
commitb2688c3a42c93446a51808f6b0f495dc250707e6 (patch)
treeefa1c52a73372a414d09f7c48d05d3896ebf54d0 /Makefile.am
parent5f5864774d1215df7a233820dfc1c1dda6999ef5 (diff)
downloadwireshark-b2688c3a42c93446a51808f6b0f495dc250707e6.tar.gz
Fix the patch-bzip2 target.
The main site URI scheme is now https. Update the URL in some other places while we're here. Change-Id: Ib03d4fd1c58dabd3cf5050dc4f79216e0b94d525 Reviewed-on: https://code.wireshark.org/review/4133 Reviewed-by: Gerald Combs <gerald@wireshark.org> (cherry picked from commit 983ae6cadee518be589b53d9b149fd2e156e8ada) Reviewed-on: https://code.wireshark.org/review/4134
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 28eea0497c..d81378451a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1155,11 +1155,11 @@ BASE_VERSION=`echo "$(VERSION)" | awk -F. '{$$3 = $$3 + 0 ; printf("%d.%d.%d"),
PREV_VERSION=`echo "$(VERSION)" | awk -F. '{$$3 = $$3 + 0 ; if ($$3 > 0) $$3-- ; printf("%d.%d.%d"), $$1, $$2, $$3}'`
PREV_DIR="wireshark-$(PREV_VERSION)"
PREV_FILE="$(PREV_DIR).tar.bz2"
-PREV_URL="http://www.wireshark.org/download/src/all-versions/$(PREV_FILE)"
+PREV_URL="https://www.wireshark.org/download/src/all-versions/$(PREV_FILE)"
patch-bzip2: distdir
if test x$(BASE_VERSION) != x$(PREV_VERSION) ; then \
- curl -z $(PREV_FILE) -o $(PREV_FILE) $(PREV_URL) && \
+ curl --time-cond $(PREV_FILE) --location --output $(PREV_FILE) $(PREV_URL) && \
tar -xjf $(PREV_FILE) && \
diff -urN $(PREV_DIR) $(distdir) | bzip2 > patch-wireshark-$(PREV_VERSION)-to-$(VERSION).bz2 && \
echo "Created patch-bzip2" ; \