summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2014-04-23 10:50:27 +0200
committerAnders Broman <a.broman58@gmail.com>2014-04-25 04:23:46 +0000
commitbd38b3152d12584b9cd31d0c49706f1cebaa087a (patch)
treedd9ffd4b9f64647e9c683085b0fb73337132a7ab /Makefile.am
parent748e0d4221eabab207a350640ce3f526c73afde9 (diff)
downloadwireshark-bd38b3152d12584b9cd31d0c49706f1cebaa087a.tar.gz
Support out-of-source checkapi
Always call $(top_srcdir)/tools/checkAPIs.pl with -sourcedir=$(srcdir) from Makefile.am to allow out-of-source 'make checkapi'. Change-Id: I60d7e0079984a8ededdacf4517a0738486fa7973 Reviewed-on: https://code.wireshark.org/review/1294 Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8d41d8509a..2390286d15 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1218,7 +1218,8 @@ dumpabi:
$(MAKE) -C wsutil dumpabi-libwsutil
checkapi_local:
- $(PERL) tools/checkAPIs.pl -build \
+ $(PERL) $(top_srcdir)/tools/checkAPIs.pl -build \
+ -sourcedir=$(srcdir) \
$(TSHARK_TAP_SRC) \
$(wireshark_SOURCES)
# $(EXTRA_wireshark_SOURCES)