summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-07-13 10:34:50 -0700
committerGuy Harris <guy@alum.mit.edu>2015-07-13 17:35:15 +0000
commit9f03aa131e851447f6c3a89b6e57ff560df0afe2 (patch)
tree74146781896611d07c324649513c8aef1ce112d8 /Makefile.am
parent7b9b3d469375c9d3ac1b5f7280ca64413b4811bf (diff)
downloadwireshark-9f03aa131e851447f6c3a89b6e57ff560df0afe2.tar.gz
On OS X, add an rpath for the Qt frameworks, and remove it in the app bundle.
Qt 5.5 and later have @rpath-based install names for the frameworks, which means that, if they're not installed in some frameworks directory searched by default (such as /Library/Frameworks) - which is the default case with the Qt installer - they won't be found by default. Add the directory in which the frameworks exist as an rpath in the Wireshark binary, so that they'll be found, and then remove it from the Wireshark binary in the app bundle, as the directory in which the frameworks exist on the machine on which Wireshark was built is irrelevant to the machines on which it's being deployed - the frameworks are included in the bundle, and we already add an rpath to find them there. Change-Id: I54e033743e7b17eab26976064dcd7cd000f97c78 Reviewed-on: https://code.wireshark.org/review/9625 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f09133c2c..d130c43062 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -372,7 +372,7 @@ if HAVE_GTK
wireshark_gtk_LDFLAGS = -export-dynamic
endif
if HAVE_Qt
-wireshark_LDFLAGS = -export-dynamic
+wireshark_LDFLAGS = -export-dynamic @Qt_LDFLAGS@
endif
endif