summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-05-14 05:38:27 +0100
committerJoão Valverde <j@v6e.pt>2016-05-19 13:24:13 +0000
commita8537e07ace76d74fe8db676a0ffd20bf35b1a3a (patch)
treee2cfffa3050575690c68c1a6a1d10208789fe77a /configure.ac
parent1c842bc1250a941afce1c11edcccf8ac1aa8f2cd (diff)
downloadwireshark-a8537e07ace76d74fe8db676a0ffd20bf35b1a3a.tar.gz
configure.ac: Don't require flex unless we need it
We need it when we don't have the flex-generated files (i.e., we're building from git rather than a ("make dist") source tarball). Change-Id: I824ce4b7f2a8f767e096de050cb3cd0b0449ed62 Reviewed-on: https://code.wireshark.org/review/15423 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index aac1c142ca..83d0642024 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,13 +176,15 @@ AS_IF([$YACC -V >/dev/null 2>&1],
[AC_MSG_RESULT(no)
AS_IF([test ! -f wiretap/ascend.c],
AC_MSG_ERROR([I couldn't find yacc (or bison or ...); make sure it's installed and in your path]))])
+dnl AM_MISSING_PROG(YACC, bison)
+
+AC_PROG_LEX
+AS_IF([test "x$LEX" != xflex],
+ [AS_UNSET(LEX)
+ AS_IF([test ! -f wiretap/ascend_scanner.c],
+ AC_MSG_ERROR(I couldn't find flex; make sure it's installed and in your path))])
+AM_MISSING_PROG(LEX, flex)
-AM_PROG_LEX
-AC_PATH_PROG(LEX, flex)
-if test "x$LEX" = x
-then
- AC_MSG_ERROR(I couldn't find flex; make sure it's installed and in your path)
-fi
AC_PATH_PROG(POD2MAN, pod2man)
if test "x$POD2MAN" = x
then