summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-07-19 00:23:37 -0700
committerGuy Harris <guy@alum.mit.edu>2014-07-19 07:24:01 +0000
commitf724cae763a9090000980340525bfc8c855a15b5 (patch)
treeb453808075af9b69bf9efc246ae4076ca0e67a71 /configure.ac
parentbf514a5b3d40c66277db16e7435ac46536e98054 (diff)
downloadwireshark-f724cae763a9090000980340525bfc8c855a15b5.tar.gz
Only ABI-check strncasecmp.h if strncasecmp() is part of the API/ABI.
Some routines Wireshark uses are present in some, but not all, platforms; for routines that would be used on all platforms, libwsutil provides its own implementations on platforms that lack them. On platforms that provide a routine, that routine will not be part of the API and ABI, and, if we do an API or ABI check using the header libwsutil provides to declare the function on platforms that lack it, we may have a collision between the declaration in our header and the declaration in a system header. There's no guarantee that we can make them match, as the declaration might differ from platform to platform and from platform version to platform version, so we simply leave the header file out of the check if we have the function on the platform on which we're checking the API or ABI. Change-Id: I8a23e63d9e17e5c1f5a83304dbe14d1e7df22e7e Reviewed-on: https://code.wireshark.org/review/3115 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2850b4bb23..5c663f63e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2540,10 +2540,15 @@ AC_SUBST(GETOPT_LO)
AC_CHECK_FUNC(strncasecmp,
[
+ STRNCASECMP_INCLUDES=""
STRNCASECMP_LO=""
AC_DEFINE(HAVE_STRNCASECMP, 1, [Define to 1 if you have the strncasecmp function.])
],
- STRNCASECMP_LO="strncasecmp.lo")
+ [
+ STRNCASECMP_INCLUDES="strncasecmp.h"
+ STRNCASECMP_LO="strncasecmp.lo"
+ ])
+AC_SUBST(STRNCASECMP_INCLUDES)
AC_SUBST(STRNCASECMP_LO)
AC_CHECK_FUNCS(mkstemp mkdtemp)