summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-07-01 17:47:55 -0700
committerGuy Harris <guy@alum.mit.edu>2015-08-14 18:39:03 +0000
commit489b06e9868fce46d8b2824161861c73dd9153e3 (patch)
treec0db77b8c5c83c64b329fec13172ad6fa33ca097 /configure.ac
parent2edab9f8f3b36fdb2fd078b9f594ed5b1c9a31f8 (diff)
downloadwireshark-489b06e9868fce46d8b2824161861c73dd9153e3.tar.gz
Make some inconsistent configuration options errors.
This way, if you ask for both setuid and setcap installation of dumpcap, it will fail, rather than silently (other than a message you might miss) ignoring the request for setuid installation. See bug 10246. Also: if you ask for setuid or setcap installation of dumpcap, but dumpcap isn't built, it'll let you know that there's nothing to make setuid/setcap, and fail; if you ask for setcap installation of dumpcap, but setcap wasn't found, it'll let you know that it can't install it setcap, and fail; so that it won't silently (other than a message you might miss) ignore those requests, either. Change-Id: Ibc01593e59fd1cd1be8c68d8cdacbfdca863efa0 Reviewed-on: https://code.wireshark.org/review/2771 Reviewed-by: Guy Harris <guy@alum.mit.edu> (cherry picked from commit 096aca67defc82e72daeb45e109d13227cc80eed) Reviewed-on: https://code.wireshark.org/review/10033
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index cab8fa7c83..47256376ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2262,9 +2262,11 @@ if test "x$enable_setcap_install" = "xno" ; then
AC_MSG_RESULT(no)
else
if test "x$SETCAP" = "x" ; then
- AC_MSG_RESULT(no. Setcap not found)
+ AC_MSG_RESULT(setcap not found)
+ AC_MSG_ERROR([Setcap install was requested, but setcap was not found])
elif test "x$enable_dumpcap" = "xno" ; then
- AC_MSG_ERROR(Setcap install works only with dumpcap but dumpcap is disabled)
+ AC_MSG_RESULT(dumpcap disabled)
+ AC_MSG_ERROR([Setcap install works only with dumpcap, but dumpcap is disabled])
else
AC_MSG_RESULT(yes)
fi
@@ -2284,9 +2286,11 @@ if test "x$enable_setuid_install" = "xno" ; then
else
if test "x$enable_setcap_install" = "xyes" ; then
enable_setuid_install=no
- AC_MSG_RESULT(no; using setcap instead)
+ AC_MSG_RESULT(setcap and setuid both selected)
+ AC_MSG_ERROR(You must choose one of setcap install and setuid install)
elif test "x$enable_dumpcap" = "xno" ; then
- AC_MSG_ERROR(Setuid install works only with dumpcap but dumpcap is disabled)
+ AC_MSG_RESULT(dumpcap disabled)
+ AC_MSG_ERROR([Setuid install works only with dumpcap, but dumpcap is disabled])
else
AC_MSG_RESULT(yes)
fi