summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-04-20 15:44:53 -0700
committerGuy Harris <guy@alum.mit.edu>2014-04-20 22:47:18 +0000
commit68f9811b1bed1397d2ba06af63488fe16bc5bb5e (patch)
treebf1c124437efd4d3c1c37a4da10b926aac9b3cc5 /configure.ac
parent62592ee5ec81b78c5cd9755d7d984e7c72722c9a (diff)
downloadwireshark-68f9811b1bed1397d2ba06af63488fe16bc5bb5e.tar.gz
Don't distinguish between "GCC" and "Clang" extra -W flags.
We test whether a given compiler supports a given -W flag, so we don't need to separate them and check them only for particular compilers. To make that even clearer, rename the --enable option from --enable-extra-gcc-checks to --enable-extra-compiler-checks, and document it as just "do additional -W checks", and rename the WIRESHARK_EXTRA_GCC_ CMake variables to WIRESHARK_EXTRA_COMPILER_. Sync up the lists of warning flags in CMake with the lists in autoconf. Uncomment -Wdocumentation while we're at it. If it doesn't work *at all*, comment it out until it's fixed, or, better yet, fix it; if it still produces warnings, we just leave it among the "extra" flags. Change-Id: I4042affdade612e4025e2881d08f1ca69d759626 Reviewed-on: https://code.wireshark.org/review/1226 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 13 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 4b89d709d3..8cb02dd3bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -769,11 +769,13 @@ AC_WIRESHARK_CHECK_UNKNOWN_WARNING_OPTION_ERROR
AC_WIRESHARK_CHECK_NON_CXX_WARNING_OPTION_ERROR
#
-# Try to add some additional gcc checks to CFLAGS
+# Try to add some additional checks to CFLAGS.
+# These are not enabled by default, because the warnings they produce
+# are very hard or impossible to eliminate.
#
-AC_ARG_ENABLE(extra-gcc-checks,
- AC_HELP_STRING( [--enable-extra-gcc-checks],
- [do additional -W checks in GCC @<:@default=no@:>@]),
+AC_ARG_ENABLE(extra-compiler-checks,
+ AC_HELP_STRING( [--enable-extra-compiler-checks],
+ [do additional -W checks @<:@default=no@:>@]),
[
wireshark_extra_flags=$enableval
if test $enableval != no
@@ -812,21 +814,14 @@ AC_ARG_ENABLE(extra-gcc-checks,
# this one for now.
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wcast-align)
- fi
-],)
-
-#
-# Try to add some additional clang checks to CFLAGS
-#
-AC_ARG_ENABLE(extra-clang-checks,
- AC_HELP_STRING( [--enable-extra-clang-checks],
- [do additional -W checks in Clang @<:@default=no@:>@]),
-[
- wireshark_extra_flags=$enableval
- if test $enableval != no
- then
+ #
+ # Some code blocks this for now.
+ #
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wunreachable-code)
- #AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wdocumentation)
+ #
+ # Some code blocks this for now.
+ #
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wdocumentation)
fi
],)