summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBill Meier <wmeier@newsguy.com>2013-12-21 18:16:07 +0000
committerBill Meier <wmeier@newsguy.com>2013-12-21 18:16:07 +0000
commit6ec4ba58a18298d443d87de2cd8bd64dc97464e1 (patch)
tree6330b73beecdb0d297f92feb559b9f6c95e7b3f8 /configure.ac
parent58289a8ba05a62e54932e49bc05c59afec57e6cd (diff)
downloadwireshark-6ec4ba58a18298d443d87de2cd8bd64dc97464e1.tar.gz
If Gtk >= 3.10, allow use of deprecated Gtk features (and prevent 'deprecated' warnings);
Given that Wireshark is moving to QT, the Wireshark changes required to fix the features deprecated in Gtk 3.10 will not be done. svn path=/trunk/; revision=54337
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 69884ecc51..8fec259059 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1490,7 +1490,13 @@ if test "$have_gtk" = "yes" ; then
CPPFLAGS="-DGDK_PIXBUF_DISABLE_DEPRECATED $CPPFLAGS"
CPPFLAGS="-DGDK_DISABLE_DEPRECATED $CPPFLAGS"
- CPPFLAGS="-DGTK_DISABLE_DEPRECATED $CPPFLAGS"
+ if test \( $gtk_config_major_version -eq 3 -a $gtk_config_minor_version -ge 10 \) ; then
+ ## Allow use of deprecated & disable deprecated warnings if Gtk >= 3.10;
+ ## The deprecations in Gtk 3.10 will not be fixed ...
+ CPPFLAGS="-DGDK_DISABLE_DEPRECATION_WARNINGS $CPPFLAGS"
+ else
+ CPPFLAGS="-DGTK_DISABLE_DEPRECATED $CPPFLAGS"
+ fi
CPPFLAGS="-DGTK_DISABLE_SINGLE_INCLUDES $CPPFLAGS"
if test ! \( $gtk_config_major_version -eq 2 -a $gtk_config_minor_version -lt 20 \) ; then
# Enable GSEAL when building with GTK > 2.20