summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-12-24 17:10:40 -0800
committerGuy Harris <guy@alum.mit.edu>2014-12-25 09:07:51 +0000
commita8f5bbedf14d73b8e57c6d1662d58bfd753b63f3 (patch)
tree2302232630b9ab29da45379b51fb4b1f07840363 /configure.ac
parent144655ec9c820a25666c78b99561799aa3fdcc25 (diff)
downloadwireshark-a8f5bbedf14d73b8e57c6d1662d58bfd753b63f3.tar.gz
Check for getopt_long(), not getopt().
We support three types of platforms: 1) UN*Xes that have both getopt() and getopt_long(); 2) UN*Xes that have getopt() but not getopt_long(); 3) Windows, which has neither. Checking for getopt_long() lets us distinguish between 1) and 2) and build getopt_long() for them. Change-Id: I642f28202e0b36d2a56a71a80e7c9bd7d6140ba6 Reviewed-on: https://code.wireshark.org/review/6047 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 64ac1f573f..207d40990f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2553,9 +2553,9 @@ AC_C_BIGENDIAN
AC_PROG_GCC_TRADITIONAL
GETOPT_LO=""
-AC_CHECK_FUNC(getopt,
+AC_CHECK_FUNC(getopt_long,
[GETOPT_LO=""
- AC_DEFINE(HAVE_GETOPT, 1, [Define to 1 if you have the getopt function.])
+ AC_DEFINE(HAVE_GETOPT_LONG, 1, [Define to 1 if you have the getopt_long function.])
],
GETOPT_LO="wsgetopt.lo"
)