summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-10-09 08:39:27 -0700
committerGuy Harris <guy@alum.mit.edu>2015-10-09 15:40:01 +0000
commit12446da29bf57dc95b9050cc0ec669d60a381dc0 (patch)
treea24c7c4fc523d280601b3ac95e5a695641d64b5e /configure.ac
parenta7ab4af2ab4db5d5fdd5d489bf6b4171a8b1b8d9 (diff)
downloadwireshark-12446da29bf57dc95b9050cc0ec669d60a381dc0.tar.gz
Now that we're using AC_PROG_CC_STDC, let it handle HP C.
AC_PROG_CC_STDC should be setting whatever flags are needed for ISO C plus extensions, including requesting C99 if available. Don't set -Ae ourselves for HP C. Change-Id: Icd4dfc0c2078586d5773075ee25c40bfc787a482 Reviewed-on: https://code.wireshark.org/review/10910 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index f6d6945261..5fe2f39151 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1284,15 +1284,16 @@ else
case "$host_os" in
hpux*)
#
- # HP's ANSI C compiler; flags suggested by Jost Martin.
- # "-Ae" for ANSI C plus extensions such as "long long".
- # "+O2", for optimization. XXX - works with "-g"?
+ # AC_PROG_CC_STDC should already have added whatever
+ # flags are necessary for ISO C - C99 if available,
+ # otherwise C89 - with extensions.
#
- # HP's ANSI C++ compiler doesn't support "-Ae", but
- # does support "+O2", at least according to the
- # documentation I can find online.
+ # Add +O2, for optimization, as suggested by Jost Martin.
+ # XXX - works with "-g"?
#
- CFLAGS="-Ae +O2 $CFLAGS"
+ # +O2 is supported both by the C and C++ compiler.
+ #
+ CFLAGS="+O2 $CFLAGS"
if test "$CC" = "$CC_FOR_BUILD"; then
#
# We're building the build tools with the same
@@ -1303,7 +1304,7 @@ else
CFLAGS_FOR_BUILD="-Ae +O2 $CFLAGS"
fi
CXXFLAGS="+O2 $CFLAGS"
- AC_MSG_RESULT(HP ANSI C compiler - added -Ae +O2)
+ AC_MSG_RESULT(HP C/C++ compiler - added +O2)
;;
solaris*)
#