summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2015-11-25 00:45:06 +0000
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2015-11-27 22:22:06 +0000
commit7c8314a68340a331c43f3232f6158a9c3afff641 (patch)
tree2e648c0dc0c755e8820c9b0bfc3a8b66ea560d43 /configure.ac
parentd7f12436709e40d58d7fcdfbcdd08740c039e162 (diff)
downloadwireshark-7c8314a68340a331c43f3232f6158a9c3afff641.tar.gz
Fix ISO C forbids an empty translation unit [-Wpedantic] (airpcap)
Autotools only warning. Change-Id: I30f33d2f8611d662dbc62326862707bf05ad3f60 Reviewed-on: https://code.wireshark.org/review/12150 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 0 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 7a31fc71cf..53f291ebdd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -694,21 +694,18 @@ linux*)
AC_DEFINE(HAVE_LIBNL, 1, [Enable libnl support])
AC_DEFINE(HAVE_LIBNL3, 1, [libnl version 3])
libnl_message="yes (v3)"
- enable_airpcap=no
elif (test "${have_libnl2}" = "yes"); then
CFLAGS="$CFLAGS $LIBNL2_CFLAGS"
LIBS="$LIBS $LIBNL2_LIBS"
AC_DEFINE(HAVE_LIBNL, 1, [Enable libnl support])
AC_DEFINE(HAVE_LIBNL2, 1, [libnl version 2])
libnl_message="yes (v2)"
- enable_airpcap=no
elif (test "${have_libnl1}" = "yes"); then
CFLAGS="$CFLAGS $LIBNL1_CFLAGS"
LIBS="$LIBS $LIBNL1_LIBS"
AC_DEFINE(HAVE_LIBNL, 1, [Enable libnl support])
AC_DEFINE(HAVE_LIBNL1, 1, [libnl version 1])
libnl_message="yes (v1)"
- enable_airpcap=no
else
if test x$want_libnl = "xyes"; then
case "$libnl_version" in
@@ -2221,29 +2218,6 @@ else
AC_WIRESHARK_PCAP_CHECK
fi
-
-dnl Check for airpcap
-dnl We might want to remove this entirely unless we want to support
-dnl AutoTools on Windows.
-AC_MSG_CHECKING(whether to include airpcap support)
-AC_ARG_ENABLE(airpcap,
- AC_HELP_STRING( [--enable-airpcap],
- [use AirPcap in Wireshark @<:@default=no@:>@]),
- enable_airpcap=$enableval, enable_airpcap=no)
-
-if test x$enable_airpcap = xyes; then
- if test "x$want_pcap" = "xno" ; then
- enable_airpcap=no
- AC_MSG_RESULT(pcap not available - disabling airpcap)
- else
- AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_AIRPCAP, 1, [Enable AirPcap])
- fi
-else
- AC_MSG_RESULT(no)
-fi
-
-
dnl dumpcap check
AC_MSG_CHECKING(whether to build dumpcap)