summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-07-01 12:46:38 -0700
committerGuy Harris <guy@alum.mit.edu>2014-07-01 19:47:07 +0000
commitaa0f80981a34ce4361e97748a51b483d083cd8ea (patch)
treebc71ecec4cc786ccdbe406630d1fedc7349be23f /configure.ac
parentb378f725453526883d087b5e57165dd7dee13c67 (diff)
downloadwireshark-aa0f80981a34ce4361e97748a51b483d083cd8ea.tar.gz
Don't check for -Wl,{option} support.
Not all AC_WIRESHARK_LDFLAGS_CHECK flags are -Wl,{option} flags, so don't check for that first. If we want to check for specific compilers and linkers, we should do that, not for -Wl,{option} support. Change-Id: Ib9581d4a1573a1ffa2493ce08e6d5845d2601352 Reviewed-on: https://code.wireshark.org/review/2755 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 0 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index ee431db579..15f910c59b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -216,28 +216,6 @@ if test "x$GCC" = "xyes" -o "x$CC" = "xclang" ; then
ac_supports_gcc_flags=yes
fi
-#
-# Set "ac_supports_W_linker_passthrough" if the compiler is known to
-# support "-Wl,{options}" to pass options through to the linker.
-# Currently, we assume GCC, xlc, and clang do; other compilers should
-# be added here.
-#
-if test "x$GCC" = "xyes" -o "x$CC" = "xxlc" -o "x$CC" = "xclang" ; then
- ac_supports_W_linker_passthrough=yes
-fi
-
-#
-# Set "ac_supports_W_linker_passthrough" if the compiler is known to
-# support "-Wl,{option}" to pass options through to the linker.
-# Currently, we assume GCC and clang do; other compilers should
-# be added here.
-#
-# XXX - do this with a compiler test?
-#
-if test "x$GCC" = "xyes" -o "x$CC" = "xclang" ; then
- ac_supports_W_linker_passthrough=yes
-fi
-
if test "x$CC_FOR_BUILD" = x
then
CC_FOR_BUILD=$CC