summaryrefslogtreecommitdiff
path: root/docbook/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@zing.org>2014-11-02 13:20:08 -0800
committerGerald Combs <gerald@wireshark.org>2014-11-09 05:12:09 +0000
commit04aad36c0e9179ceb36b9459d52aad0059b7d1f2 (patch)
tree6678632b4620b8f107c306c7d6541641bef01854 /docbook/CMakeLists.txt
parent502085662fd22deadd7d405a5bf13edbaff2516c (diff)
downloadwireshark-04aad36c0e9179ceb36b9459d52aad0059b7d1f2.tar.gz
Convert the Lua reference to AsciiDoc.
Move it to the Developer's Guide while we're here. Nudge the markup in epan/wslua where needed. Note that we should probably convert it to AsciiDoc (if we're going to keep it in the DG) or Doxygen. Change-Id: Ie175111043f98b7a37eeeb8d185a833d8e866f8b Reviewed-on: https://code.wireshark.org/review/5203 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'docbook/CMakeLists.txt')
-rw-r--r--docbook/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/docbook/CMakeLists.txt b/docbook/CMakeLists.txt
index 8af975a1db..9c4ee7ac11 100644
--- a/docbook/CMakeLists.txt
+++ b/docbook/CMakeLists.txt
@@ -50,7 +50,6 @@ set(WSUG_FILES
WSUG_chapter_work.xml
wsug_src/WSUG_meta_info.xml
WSUG_preface.xml
- wsluarm.xml
ws.css
)
@@ -66,6 +65,7 @@ set(WSDG_ASCIIDOC_FILES
wsug_src/WSUG_chapter_use.asciidoc
wsug_src/WSUG_chapter_work.asciidoc
wsug_src/WSUG_preface.asciidoc
+ wsluarm.asciidoc
)
set(WSUG_GRAPHICS
@@ -253,6 +253,7 @@ MACRO( ASCIIDOC2DOCBOOK _asciidocsource _conf_files )
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
COMMAND ${A2X_EXECUTABLE}
--verbose
+ --attribute=build_dir=${CMAKE_CURRENT_BINARY_DIR}
--attribute=docinfo
--destination-dir=${CMAKE_CURRENT_BINARY_DIR}
--asciidoc-opts=${_conf_opts}
@@ -299,6 +300,7 @@ MACRO( ASCIIDOC2CHAPTER _asciidocsource _conf_files )
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
COMMAND ${A2X_EXECUTABLE}
--verbose
+ --attribute=build_dir=${CMAKE_CURRENT_BINARY_DIR}
--destination-dir=${CMAKE_CURRENT_BINARY_DIR}
--asciidoc-opts=${_conf_opts}
--no-xmllint
@@ -366,7 +368,6 @@ ADD_CUSTOM_COMMAND(
add_custom_target(
user_guides ALL
DEPENDS
- wsluarm
wsug_html_chunked/index.html
wsug_html/index.html
user-guide-a4.pdf