summaryrefslogtreecommitdiff
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2004-03-23 21:19:58 +0000
committerGuy Harris <guy@alum.mit.edu>2004-03-23 21:19:58 +0000
commit121f06fab70d77c4babb512924b2b8d3c3921944 (patch)
tree9dba3131d845040ea0ab402a8b3e4a5147d5d315 /epan/Makefile.am
parentbf1315c25615bdd7d5ebff4245d8ba37b525871e (diff)
downloadwireshark-121f06fab70d77c4babb512924b2b8d3c3921944.tar.gz
Make "epan_init()" take, as additional arguments, pointers to routines
that dissectors should call to report file open and read errors, and have "report_open_failure()" and "report_read_failure()" call through those pointers, rather than being defined and exported by the application using libethereal - instead, the application would define those functions and pass pointers to them to 'epan_init()". Move "report_err.h" to the epan directory, as the functions it declares are now part of the libethereal API. svn path=/trunk/; revision=10470
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index ca49c06a39..52a082c378 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -2,7 +2,7 @@
# Automake file for the EPAN library
# (Ethereal Protocol ANalyzer Library)
#
-# $Id: Makefile.am,v 1.43 2004/03/22 21:29:52 gerald Exp $
+# $Id: Makefile.am,v 1.44 2004/03/23 21:19:56 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@ethereal.com>
@@ -52,7 +52,7 @@ libethereal_la_SOURCES = \
column-utils.h \
epan.c \
epan.h \
- epan_dissect.h \
+ epan_dissect.h \
except.c \
except.h \
exceptions.h \
@@ -79,6 +79,7 @@ libethereal_la_SOURCES = \
proto.h \
resolv.c \
resolv.h \
+ report_err.h \
slab.h \
sna-utils.c \
sna-utils.h \