summaryrefslogtreecommitdiff
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>2001-12-18 19:09:08 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>2001-12-18 19:09:08 +0000
commit791f5774d0fdabdb706bfd7056e534713cc4e4d6 (patch)
tree35f987f9914fead0fb5fefe79df280b7340831b4 /epan/Makefile.am
parent4e013a44de86f8146cfd7d440adb67366e37273a (diff)
downloadwireshark-791f5774d0fdabdb706bfd7056e534713cc4e4d6.tar.gz
Provide for per-protocol-tree data in the proto_tree code.
Put a hash-table of "interesting" fields in the per-proto-tree data. The dfilter code records which fields/protocols are "interesting" (by which I mean, their value or existence is checked). Thus, the proto_tree routines can create special arrays of field_info*'s that are ready for the dfilter engine to use during a filter operation. Also store the "proto_tree_is_visible" boolean, renamed "visible", in the per-proto-tree data. Move epan_dissect_t to its own header file to make #include dependencies easier to handle. Provide epan_dissect_fill_in_columns(), which accepts just the epan_dissect_t* as an argument. epan_dissect_new() needs to be followed by epan_dissect_run() for the dissection to actually take place. Between those two calls, epan_dissect_prime_dfilter() can be run 0, 1, or multiple times in order to prime the empty proto_tree with the "intersesting" fields from the dfilter_t. svn path=/trunk/; revision=4422
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 02e2c2b782..cefe353d0d 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -2,7 +2,7 @@
# Automake file for the EPAN library
# (Ethereal Protocol ANalyzer Library)
#
-# $Id: Makefile.am,v 1.29 2001/11/22 03:07:06 hagbard Exp $
+# $Id: Makefile.am,v 1.30 2001/12/18 19:09:03 gram Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@zing.org>
@@ -46,6 +46,7 @@ libethereal_a_SOURCES = \
column-utils.h \
epan.c \
epan.h \
+ epan_dissect.h \
except.c \
except.h \
exceptions.h \