summaryrefslogtreecommitdiff
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2004-09-05 10:38:04 +0000
committerGuy Harris <guy@alum.mit.edu>2004-09-05 10:38:04 +0000
commit816a1793111e3dcda1cf5adcb7d9fbbf96545212 (patch)
tree53f1dfe032e812a4e681cec54d7b2eb10d54a834 /epan/Makefile.am
parent37cebd939c459b9ecf6b4c0f92bb68ab1acd4060 (diff)
downloadwireshark-816a1793111e3dcda1cf5adcb7d9fbbf96545212.tar.gz
Name the variables that have the names of ".lo" files as _LO, not _O;
put the name of the ".o" files into _O variables (I'm not sure whether the current .am files automatically support building programs statically linked with libethereal, as a result of using libtool; if so, the _O versions of those variables aren't necessary, and, if not, we probably need to use them). Use the _LO variables in libethereal_la_LIBADD and libethereal_la_DEPENDENCIES. (This means that we use "g_ascii_strtoull.lo" rather than "g_ascii_strtoull.o" to make the libethereal shared library; that's what we need to do, but we weren't doing it.) svn path=/trunk/; revision=11906
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 933e653fd2..1214e92a70 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -69,8 +69,8 @@ MAINTAINERCLEANFILES = \
#
# Add the object files for missing routines, if any.
#
-libethereal_la_LIBADD = @G_ASCII_STRTOULL_O@ @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la
-libethereal_la_DEPENDENCIES = @G_ASCII_STRTOULL_O@ @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la
+libethereal_la_LIBADD = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la
+libethereal_la_DEPENDENCIES = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la
tvbtest: tvbtest.o tvbuff.o except.o strutil.o
$(LINK) -o tvbtest tvbtest.o tvbuff.o except.o strutil.o `glib-config --libs`