summaryrefslogtreecommitdiff
path: root/epan/wmem/Makefile.am
diff options
context:
space:
mode:
authorEvan Huus <eapache@gmail.com>2012-10-24 02:04:40 +0000
committerEvan Huus <eapache@gmail.com>2012-10-24 02:04:40 +0000
commit84cc3daa3b2a596660492b730fe4e27ebb595a5f (patch)
treec2f2354a4edd2562cadb75166967c4f997dea87d /epan/wmem/Makefile.am
parent7044125704da6d9ead243c2ead3e79eee70bc1be (diff)
downloadwireshark-84cc3daa3b2a596660492b730fe4e27ebb595a5f.tar.gz
Basic skeleton for wmem.
https://www.wireshark.org/lists/wireshark-dev/201210/msg00178.html svn path=/trunk/; revision=45746
Diffstat (limited to 'epan/wmem/Makefile.am')
-rw-r--r--epan/wmem/Makefile.am71
1 files changed, 71 insertions, 0 deletions
diff --git a/epan/wmem/Makefile.am b/epan/wmem/Makefile.am
new file mode 100644
index 0000000000..7c803f1c1c
--- /dev/null
+++ b/epan/wmem/Makefile.am
@@ -0,0 +1,71 @@
+# Makefile.am
+# Automake file for Wireshark Memory Manager
+#
+# $Id$
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+INCLUDES = -I$(top_srcdir)
+
+include Makefile.common
+
+if HAVE_WARNINGS_AS_ERRORS
+AM_CFLAGS = -Werror
+endif
+
+AM_CPPFLAGS = $(LIBWMEM_CFLAGS)
+
+noinst_LTLIBRARIES = libwmem.la
+
+CLEANFILES = \
+ libwmem.a \
+ libwmem.la \
+ *~
+
+DISTCLEANFILES =
+
+MAINTAINERCLEANFILES = \
+ Makefile.in
+
+libairpdcap_la_SOURCES = \
+ $(LIBWMEM_SRC) \
+ $(LIBWMEM_INCLUDES)
+
+EXTRA_DIST = \
+ Custom.common \
+ Makefile.common \
+ Makefile.nmake
+
+checkapi:
+ $(PERL) ../../tools/checkAPIs.pl -g termoutput -build \
+ $(LIBWMEM_SRC)
+
+
+#
+# Editor modelines - http://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#