summaryrefslogtreecommitdiff
path: root/plugins/gryphon/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>1999-12-26 22:38:07 +0000
committerGerald Combs <gerald@wireshark.org>1999-12-26 22:38:07 +0000
commit45babe7bb5b9348a9ba6cad2e8aed26bfd10e3a3 (patch)
treecceb02d34be8c7f835ac3479456855d35e9e6e73 /plugins/gryphon/Makefile.am
parentc91afab6c988371f877216e5687f3a4c7f8ad13f (diff)
downloadwireshark-45babe7bb5b9348a9ba6cad2e8aed26bfd10e3a3.tar.gz
Integrate libtool/libltdl with the plugin code. Add libtool and libltdl
to the distribution. svn path=/trunk/; revision=1379
Diffstat (limited to 'plugins/gryphon/Makefile.am')
-rw-r--r--plugins/gryphon/Makefile.am46
1 files changed, 33 insertions, 13 deletions
diff --git a/plugins/gryphon/Makefile.am b/plugins/gryphon/Makefile.am
index bd0ef583a1..9a20ed3c71 100644
--- a/plugins/gryphon/Makefile.am
+++ b/plugins/gryphon/Makefile.am
@@ -1,21 +1,41 @@
# Makefile.am
-# fichier Automake pour gryphon
+# Automake file for Ethereal/Gryphon
#
+# $Id: Makefile.am,v 1.2 1999/12/26 22:37:39 gerald Exp $
+#
+# Ethereal - Network traffic analyzer
+# By Steve Limkemann <stevelim@dgtech.com>
+# Copyright 1998 Steve Limkemann
+#
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+INCLUDES = -I$(top_srcdir) -I$(includedir)
-ETHEREAL_DIR=../..
+libdir = $(prefix)/share/@PACKAGE@/plugins/0.8
-bin_PROGRAMS = gryphon
+lib_LTLIBRARIES = gryphon.la
+gryphon_la_SOURCES = packet-gryphon.c packet-gryphon.h
+gryphon_la_LDFLAGS = -module -avoid-version
+
+# Libs must be cleared, or else libtool won't create a shared module.
+# If your module needs to be linked against any particular libraries,
+# add them here.
+LIBS =
CLEANFILES = \
- packet-gryphon.o
gryphon
*~
-
-gryphon_SOURCES = \
- packet-gryphon.c \
- packet-gryphon.h
-
-INCLUDES = -I$(ETHEREAL_DIR)
-
-gryphon: packet-gryphon.o
- $(LD) -shared -o $@ $<