summaryrefslogtreecommitdiff
path: root/ui/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2012-02-18 23:55:41 +0000
committerGuy Harris <guy@alum.mit.edu>2012-02-18 23:55:41 +0000
commit530c8c53902c2da8f49551c6874c89e319ba1534 (patch)
tree3af372a25e0c8420185112cb18ed6a5020ed0746 /ui/Makefile.am
parentb42cfb1ff1d055da56326895484a0723f514aef4 (diff)
downloadwireshark-530c8c53902c2da8f49551c6874c89e319ba1534.tar.gz
Create a libui (static) library in the ui directory, which contains the
object files from all the source files in the ui directory (but not in its subdirectories), and link the programs that need it with them. This cleans things up a little bit, and may also fix the Windows build. svn path=/trunk/; revision=41061
Diffstat (limited to 'ui/Makefile.am')
-rw-r--r--ui/Makefile.am113
1 files changed, 113 insertions, 0 deletions
diff --git a/ui/Makefile.am b/ui/Makefile.am
new file mode 100644
index 0000000000..ebe8e0064c
--- /dev/null
+++ b/ui/Makefile.am
@@ -0,0 +1,113 @@
+# Makefile.am
+# Automake file for the common-to-all-toolkits user interface routines
+# for Wireshark
+#
+# $Id$
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+include Makefile.common
+include ../Makefile.am.inc
+
+if HAVE_WARNINGS_AS_ERRORS
+AM_CLEAN_CFLAGS = -Werror
+endif
+
+noinst_LIBRARIES = libui.a
+
+CLEANFILES = \
+ libui.a \
+ *~
+
+MAINTAINERCLEANFILES = \
+ $(GENERATED_FILES) \
+ Makefile.in
+
+RUNLEX=$(top_srcdir)/tools/runlex.sh
+
+text_import_scanner_lex.h: text_import_scanner.c
+
+wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) $(top_srcdir)/tools/make-tapreg-dotc
+ @echo Making wireshark-tap-register.c
+ @$(top_srcdir)/tools/make-tapreg-dotc wireshark-tap-register.c $(srcdir) $(WIRESHARK_TAP_SRC)
+
+libui_a_SOURCES = \
+ $(WIRESHARK_UI_SRC) \
+ $(GENERATED_C_FILES) \
+ $(GENERATED_H_FILES) \
+ $(noinst_HEADERS) \
+ $(WIRESHARK_TAP_SRC)
+
+libui_a_CFLAGS = $(AM_CLEAN_CFLAGS)
+
+libui_a_DEPENDENCIES =
+
+# Common headers
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
+
+
+doxygen:
+if HAVE_DOXYGEN
+ $(DOXYGEN) doxygen.cfg
+endif # HAVE_DOXYGEN
+
+checkapi: checkapi-base checkapi-todo
+
+checkapi-base:
+ $(PERL) ../tools/checkAPIs.pl -g deprecated-gtk \
+ $(WIRESHARK_UI_SRC) \
+ $(WIRESHARK_TAP_SRC) \
+ capture_if_details_dlg_win32.c
+
+checkapi-todo:
+ $(PERL) ../tools/checkAPIs.pl -M -g deprecated-gtk-todo \
+ $(WIRESHARK_UI_SRC) \
+ $(WIRESHARK_TAP_SRC) \
+ capture_if_details_dlg_win32.c
+
+expert_indicators.h:
+ echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+ echo >> $@
+ for elevel in chat error none note warn ; do \
+ gdk-pixbuf-csource --raw --name=expert_$${elevel}_pb_data ../image/expert_$${elevel}.png >> $@ ;\
+ done
+
+network_icons.h:
+ echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+ echo >> $@
+ for icon in bluetooth usb wired wireless ; do \
+ gdk-pixbuf-csource --raw --name=network_$${icon}_pb_data ../image/toolbar/network_$${icon}_16.png >> $@ ;\
+ done
+
+remote_icons.h:
+ echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+ echo >> $@
+ for icon in arrow globe sat ; do \
+ gdk-pixbuf-csource --raw --name=remote_$${icon}_pb_data ../image/toolbar/remote_$${icon}_16.png >> $@ ;\
+ done
+
+pipe_icon.h:
+ echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+ echo >> $@
+ gdk-pixbuf-csource --raw --name=pipe_pb_data ../image/toolbar/pipe_16.png >> $@
+
+EXTRA_DIST = \
+ $(GENERATOR_FILES) \
+ Makefile.common \
+ Makefile.nmake