summaryrefslogtreecommitdiff
path: root/ui/gtk/Makefile.am
diff options
context:
space:
mode:
authorBalint Reczey <balint@balintreczey.hu>2015-05-31 22:34:59 +0200
committerJeff Morriss <jeff.morriss.ws@gmail.com>2015-10-14 15:45:22 +0000
commit28fbc7da413f9f1aae634962808be4d744659691 (patch)
tree2cb85f76086602f9134e72818f7188c688e052b7 /ui/gtk/Makefile.am
parent58ef8e0be53353d87b91afad1c37120822c2c69e (diff)
downloadwireshark-28fbc7da413f9f1aae634962808be4d744659691.tar.gz
gtk: Don't handle deprecation warnings as errors
This fixes compilation with latest gdk-pixbuf. I plan rewriting the code to drop deprecaated function usage in a different commit and reverting this one. [Cherry-picked to master-1.12 together with I85092753058cd2e5cda527e4321a7d92ac38facd to get master-1.12 compiling with warnings-as-errors enabled.] Ping-Bug: 10750 Change-Id: I400e34e625b147a4858e73240602d75910c6eece Reviewed-on: https://code.wireshark.org/review/8720 Reviewed-by: Anders Broman <a.broman58@gmail.com> (cherry picked from commit f1a6ba1aa2f86b86613089099391aa005163a2f7) Reviewed-on: https://code.wireshark.org/review/11031 Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com>
Diffstat (limited to 'ui/gtk/Makefile.am')
-rw-r--r--ui/gtk/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/ui/gtk/Makefile.am b/ui/gtk/Makefile.am
index 2d9f366d8a..546ca0797d 100644
--- a/ui/gtk/Makefile.am
+++ b/ui/gtk/Makefile.am
@@ -23,7 +23,7 @@ include Makefile.common
include ../../Makefile.am.inc
if HAVE_WARNINGS_AS_ERRORS
-AM_CLEAN_CFLAGS = -Werror
+AM_CLEAN_CFLAGS = -Werror -Wno-error=deprecated-declarations
endif
noinst_LIBRARIES = libgtkui.a