summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 23 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7038e7acbc..407012473a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1383,7 +1383,7 @@ if(WIN32)
)
endif()
-# sources common for wireshark, tshark, and rawshark
+# sources common for wireshark, tshark, rawshark and sharkd
set(SHARK_COMMON_SRC
cfile.c
frame_tvbuff.c
@@ -2290,6 +2290,28 @@ if(BUILD_rawshark AND PCAP_FOUND)
install(TARGETS rawshark RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
+if(BUILD_sharkd)
+ set(sharkd_LIBS
+ ui
+ ${LIBEPAN_LIBS}
+ ${APPLE_CORE_FOUNDATION_LIBRARY}
+ ${APPLE_SYSTEM_CONFIGURATION_LIBRARY}
+ )
+ set(sharkd_FILES
+ capture_opts.c
+ filter_files.c
+ sharkd.c
+ sharkd_daemon.c
+ sharkd_session.c
+ ${SHARK_COMMON_SRC}
+ )
+ add_executable(sharkd ${sharkd_FILES})
+ add_dependencies(sharkd version)
+ set_extra_executable_properties(sharkd "Executables")
+ target_link_libraries(sharkd ${sharkd_LIBS})
+ install(TARGETS sharkd RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+endif()
+
if(BUILD_dftest)
set(dftest_LIBS
${LIBEPAN_LIBS}