summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd37e34311..1f22126742 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2301,7 +2301,7 @@ else()
set(TEST_SH_BIN_DIR $<TARGET_FILE_DIR:epan>)
endif()
-add_custom_target(test-sh ALL
+add_custom_target(test-sh
COMMAND ${CMAKE_COMMAND}
-DCMAKE_MODULE_PATH=${CMAKE_MODULE_PATH}
-DTEST_SH_BIN_DIR=${TEST_SH_BIN_DIR}
@@ -2310,6 +2310,17 @@ add_custom_target(test-sh ALL
DEPENDS ${CMAKE_SOURCE_DIR}/cmake/modules/GenerateTestSh.cmake
)
+add_custom_target(test-programs
+ DEPENDS test-sh
+ exntest
+ oids_test
+ reassemble_test
+ tvbtest
+ wmem_test
+ COMMENT "Building unit test programs and wrapper"
+)
+
+
#
# Editor modelines - http://www.wireshark.org/tools/modelines.html
#