summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1896d08008..5f095beac0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -718,10 +718,11 @@ linux*)
AC_MSG_CHECKING([if nl80211.h is new enough])
AC_TRY_COMPILE([#include <linux/nl80211.h>],
[int x = NL80211_FREQUENCY_ATTR_MAX_TX_POWER;
- x = NL80211_ATTR_SUPPORTED_IFTYPES;
- x = NL80211_ATTR_SUPPORTED_COMMANDS;
- x = NL80211_ATTR_WIPHY_FREQ;
- x = NL80211_CHAN_NO_HT;],
+ x |= NL80211_ATTR_SUPPORTED_IFTYPES;
+ x |= NL80211_ATTR_SUPPORTED_COMMANDS;
+ x |= NL80211_ATTR_WIPHY_FREQ;
+ x |= NL80211_CHAN_NO_HT;
+ (void)x;],
[AC_MSG_RESULT(yes) AC_DEFINE(HAVE_NL80211, 1, [nl80211.h is new enough])],
[AC_MSG_RESULT(no)])