summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 719ae06cef..c917542472 100644
--- a/configure.ac
+++ b/configure.ac
@@ -743,6 +743,12 @@ linux*)
[enum nl80211_protocol_features x = NL80211_PROTOCOL_FEATURE_SPLIT_WIPHY_DUMP;],
[AC_MSG_RESULT(yes) AC_DEFINE(HAVE_NL80211_SPLIT_WIPHY_DUMP, 1, [SPLIT_WIPHY_DUMP is supported])],
[AC_MSG_RESULT(no)])
+
+ AC_MSG_CHECKING([for NL80211_VHT_CAPABILITY])
+ AC_TRY_COMPILE([#include <linux/nl80211.h>],
+ [enum nl80211_attrs x = NL80211_ATTR_VHT_CAPABILITY;],
+ [AC_MSG_RESULT(yes) AC_DEFINE(HAVE_NL80211_VHT_CAPABILITY, 1, [VHT_CAPABILITY is supported])],
+ [AC_MSG_RESULT(no)])
;;
*)