summaryrefslogtreecommitdiff
path: root/docbook/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'docbook/CMakeLists.txt')
-rw-r--r--docbook/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/docbook/CMakeLists.txt b/docbook/CMakeLists.txt
index 0ad3b33d51..29c64de8cd 100644
--- a/docbook/CMakeLists.txt
+++ b/docbook/CMakeLists.txt
@@ -305,15 +305,15 @@ ADD_CUSTOM_COMMAND(
set( WSDG_BUILT_DEPS ws.css wsluarm )
+set( ASCIIDOC_CONF_FILES
+ asciidoc.conf
+ asciidoctor-asciidoc.conf
+ attributes.asciidoc
+)
+
if(ENABLE_HTML_GUIDES OR ENABLE_PDF_GUIDES OR ENABLE_CHM_GUIDES)
# Generate the DocBook sources of user and developer guides
- set( ASCIIDOC_CONF_FILES
- asciidoc.conf
- asciidoctor-asciidoc.conf
- attributes.asciidoc
- )
-
ASCIIDOC2DOCBOOK(user-guide.asciidoc ASCIIDOC_CONF_FILES WSUG_SOURCE WSUG_BUILT_DEPS)
add_custom_target(user_guide_docbook DEPENDS generate_user-guide.xml)
set_target_properties(user_guide_docbook PROPERTIES FOLDER "Docbook")