summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-01-13 15:14:52 -0500
committerGaetan Nadon <memsize@videotron.ca>2011-01-13 15:14:52 -0500
commit379b0529eca8cc808c31e21afe041e36ffe82469 (patch)
tree02c2f624146a81abd93a0a3a8342f6207f1c1ac1 /Makefile.am
parenta298bf274a53c1c04b6b634b7e5bfb1f6ff62089 (diff)
downloadxscope-379b0529eca8cc808c31e21afe041e36ffe82469.tar.gz
config: move man pages into their own directory
Use services provided by XORG_MANPAGE_SECTIONS. Use standard Makefile for man pages. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 1 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 293527f..8a61eaf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,7 @@
#
#
+SUBDIRS = man
bin_PROGRAMS = xscope
AM_CFLAGS = $(CWARNFLAGS) $(XSCOPE_CFLAGS)
@@ -69,16 +70,7 @@ xscope_SOURCES = \
wcpscope.h \
x11.h
-appman_PRE = \
- xscope.man
-
-appmandir = $(APP_MAN_DIR)
-
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-
-EXTRA_DIST = $(appman_PRE) autogen.sh
MAINTAINERCLEANFILES = ChangeLog INSTALL
-CLEANFILES = $(appman_DATA)
.PHONY: ChangeLog INSTALL
@@ -90,12 +82,6 @@ ChangeLog:
dist-hook: ChangeLog INSTALL
-SUFFIXES = .$(APP_MAN_SUFFIX) .man
-
-# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
-
if LINT
# Check source code with tools like lint & sparse