summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2010-05-28 01:56:35 +0100
committerRichard Hughes <richard@hughsie.com>2010-05-28 13:49:56 +0100
commit7019d214f82caf2ba83f7b34894a4d7920708831 (patch)
tree41d3ff54dd6794c7b99e0a68ab52ebc0b751c2a3 /configure.ac
parent0ece8dea46de101bbbce876cc5a1703b3293b11f (diff)
downloadupower-7019d214f82caf2ba83f7b34894a4d7920708831.tar.gz
Add battery query support for iDevices
https://bugs.freedesktop.org/show_bug.cgi?id=28286 Signed-off-by: Richard Hughes <richard@hughsie.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 64a8af7..bc9baf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -178,11 +178,18 @@ AC_DEFINE_UNQUOTED(BACKEND, "$with_backend", [backend])
AC_SUBST(BACKEND, "$with_backend")
# only need GUdev on linux
+with_idevice=no
if test x$with_backend = xlinux; then
PKG_CHECK_MODULES(GUDEV, [gudev-1.0 >= 001])
PKG_CHECK_MODULES(USB, [libusb-1.0 >= 1.0.0])
+ PKG_CHECK_MODULES(IDEVICE, libimobiledevice-1.0 >= 0.9.7, with_idevice=yes, with_idevice=no)
+ if test x$with_idevice = xyes; then
+ AC_DEFINE(HAVE_IDEVICE, 1, [Define to 1 if AFC is going to be built])
+ fi
fi
+AM_CONDITIONAL(HAVE_IDEVICE, [test x$with_idevice = xyes])
+
# export to Makefile.am
AM_CONDITIONAL(BACKEND_TYPE_DUMMY, [test x$with_backend = xdummy])
AM_CONDITIONAL(BACKEND_TYPE_LINUX, [test x$with_backend = xlinux])
@@ -253,6 +260,7 @@ echo "
xsltproc: ${XSLTPROC}
Backend: ${with_backend}
+ libimobiledevice support: ${with_idevice}
Maintainer mode: ${USE_MAINTAINER_MODE}
Building api docs: ${enable_gtk_doc}
Building man pages: ${enable_man_pages}