summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2013-02-12 11:00:21 +0000
committerRichard Hughes <richard@hughsie.com>2013-02-12 11:08:35 +0000
commit372c2f8d2922add987683a24b5d69902e05e2f97 (patch)
treee96cfcf7144e9226daa6eb259fb9a072d56ad1b3 /configure.ac
parent9843589d2d80e6dc2b3f51338e64bd1da1c53860 (diff)
downloadupower-372c2f8d2922add987683a24b5d69902e05e2f97.tar.gz
Add a --enable-deprecated configure argument
This is turned off by default. If this is not set, then any calls to Suspend(), SuspendAllowed(), Hibernate() or HibernateAllowed() will fail with an error. The error mesage tells the user what new method to port to in logind. I'm expecting to set --enable-deprecated for Fedora 17 and 18, but turn it off for Fedora 19, so other distributions probably want to follow suit to find out what other stuff needs to be ported to the new APIs early. GNOME should already be fine, but KDE will need some solid porting as I understand it. See http://lists.freedesktop.org/archives/devkit-devel/2013-January/001339.html for more information on future plans and for rationale.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d41c156..8a4667f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,15 @@ AC_SYS_LARGEFILE
# Initialize libtool
LT_INIT
+# Build deprecated functionality
+AC_ARG_ENABLE(deprecated, [ --enable-deprecated build deprecated functionality],
+ enable_deprecated=$enableval,
+ enable_deprecated=no)
+if test "${enable_deprecated}" != no; then
+ AC_DEFINE(ENABLE_DEPRECATED, 1, [Define if we should build deprecated functionalty])
+fi
+AM_CONDITIONAL(ENABLE_DEPRECATED, test x$enable_deprecated = xyes)
+
# Build man pages?
AC_ARG_ENABLE(man-pages, [ --enable-man-pages build manual pages],enable_man_pages=$enableval,enable_man_pages=yes)
if test "${enable_man_page}" != no; then
@@ -291,6 +300,7 @@ echo "
cppflags: ${CPPFLAGS}
xsltproc: ${XSLTPROC}
+ Enable deprecated stuff: ${enable_deprecated}
Backend: ${with_backend}
libimobiledevice support: ${have_idevice}
Maintainer mode: ${USE_MAINTAINER_MODE}