summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Garzik <jgarzik@pobox.com>2005-10-25 01:56:48 -0400
committerJeff Garzik <jgarzik@pobox.com>2005-10-25 01:56:48 -0400
commit32c8037055f5fdaba9c9f401fd532c02571b66d7 (patch)
tree9bfb9a987fc4a1046530bcac0cb9245c1b3db3ba /Makefile.am
downloadethtool-32c8037055f5fdaba9c9f401fd532c02571b66d7.tar.gz
Initial import of ethtool version 3 + a few patches.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..e6b83cd
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,13 @@
+AM_CFLAGS = -Wall
+
+man_MANS = ethtool.8
+EXTRA_DIST = ethtool.8 ethtool.spec.in aclocal.m4 ChangeLog autogen.sh
+
+sbin_PROGRAMS = ethtool
+ethtool_SOURCES = de2104x.c ethtool.c ethtool-copy.h ethtool-util.h natsemi.c \
+ e1000.c realtek.c e100.c tg3.c amd8111e.c pcnet32.c \
+ fec_8xx.c
+
+dist-hook:
+ cp $(top_srcdir)/ethtool.spec $(distdir)
+