summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSteve Glendinning <steve.glendinning@smsc.com>2007-07-16 20:04:40 +0100
committerJeff Garzik <jeff@garzik.org>2007-07-26 13:21:56 -0400
commita5f8ce23307719f03727f72f1d68007213de7d5c (patch)
tree6680112a337f415fec06e11b9d4b00a8899b0b18 /Makefile.am
parent3764dec8110409fd07def332732909ba84fec752 (diff)
downloadethtool-a5f8ce23307719f03727f72f1d68007213de7d5c.tar.gz
ethtool: add register dump support for SMSC LAN911x/LAN921x
This patch adds support for SMSC's LAN911x and LAN921x families of embedded ethernet controllers to ethtool's dump registers (-d) command. This patch is for use with the smsc911x driver. Signed-off-by: Steve Glendinning <steve.glendinning@smsc.com> Signed-off-by: Jeff Garzik <jeff@garzik.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 240979e..9f4bbd3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,8 @@ sbin_PROGRAMS = ethtool
ethtool_SOURCES = ethtool.c ethtool-copy.h ethtool-util.h \
amd8111e.c de2104x.c e100.c e1000.c \
fec_8xx.c ibm_emac.c ixgb.c natsemi.c \
- pcnet32.c realtek.c tg3.c marvell.c vioc.c
+ pcnet32.c realtek.c tg3.c marvell.c vioc.c \
+ smsc911x.c
dist-hook:
cp $(top_srcdir)/ethtool.spec $(distdir)