summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2000-10-10 16:25:03 +0000
committerWerner Koch <wk@gnupg.org>2000-10-10 16:25:03 +0000
commit93f1fcf557f1c98b2a64606131e9fee3c01f9527 (patch)
treea327b6631cf269e6020610f331da3c31aa72a921 /Makefile.am
parent3fa436fd31c714494b5215f2574d10cf2c451618 (diff)
downloadlibgcrypt-93f1fcf557f1c98b2a64606131e9fee3c01f9527.tar.gz
configuraton changes, make dist should work now.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b9983fd1..82971545 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,12 +25,16 @@ endif
SUBDIRS = intl zlib jnlib util mpi cipher ${gcrypt} g10 po tools \
${agent} doc ${checks}
-EXTRA_DIST = README-alpha VERSION PROJECTS BUGS
+EXTRA_DIST = README-alpha PROJECTS BUGS
# gettext never gets it right, so we take here care of deleting the
# symlink. my_clean_gcrypt is just a kludge until we can include
# libgcrypt.
DISTCLEANFILES = gnupg-defs.h intl/libintl.h ${my_clean_gcrypt}
+
+# Add all the files listed in "distfiles" files to the distribution,
+# apply version number s to some files and create a VERSION file which
+# we need for the Prereq: patch file trick.
dist-hook:
@set -e; \
for file in `cd $(top_srcdir); find . -type f -name distfiles`; do \
@@ -43,7 +47,8 @@ dist-hook:
@set -e; \
sed -e 's/@pkg_version@/$(VERSION)/g' \
$(top_srcdir)/scripts/gnupg.spec.in \
- > $(distdir)/scripts/gnupg.spec
+ > $(distdir)/scripts/gnupg.spec ; \
+ echo "$(VERSION)" > $(distdir)/VERSION
if MAINTAINER_MODE